Resolved
The issue has been resolved, and performance has returned to normal.
Monitoring
We are currently experiencing degraded performance related to an issue with an upstream dependency. Users may notice slower API response times and a small increase in errors. Our team is investigating and will provide updates as they become available.