On March 19 between approximately 11:10 AM and 12:47 PM ET, a subset of voice calls on the Maven platform failed to escalate. Other voice functionality, including call answering, agent interaction, and in-call handling, continued to operate normally, and text-based channels were unaffected. The cause was a regression in a routine deployment to one of the integration components that handles voice escalation. An on-call engineer identified the issue and shipped a corrected release at approximately 12:40 PM ET, with escalation flows confirmed restored by 12:47 PM ET. The regression slipped through because our integration layer, the components that connect Maven to specific voice and telephony providers, did not have the same level of pre-production validation and production monitoring as our core platform. That gap is on us, and we're closing it. To prevent a recurrence, we are standing up a dedicated staging environment for voice integration components with real end-to-end escalation tests gating every release, adding production alerting and monitoring on the integration layer so anomalies are caught in minutes rather than by customer reports, and introducing fallback routing so a failure on the primary escalation path does not fail the call outright. Going forward, changes to these components will also be deployed outside of peak call-volume hours. We know voice escalation is a high-trust path. When a customer needs a human, nothing else matters. We're sorry for the disruption and appreciate your patience. If you'd like to discuss the incident or the remediation plan in more detail, please reach out to your account team directly.
Resolved
On March 19 between approximately 11:10 AM and 12:47 PM ET, a subset of voice calls on the Maven platform failed to escalate. Other voice functionality, including call answering, agent interaction, and in-call handling, continued to operate normally, and text-based channels were unaffected. The cause was a regression in a routine deployment to one of the integration components that handles voice escalation. An on-call engineer identified the issue and shipped a corrected release at approximately 12:40 PM ET, with escalation flows confirmed restored by 12:47 PM ET. The regression slipped through because our integration layer, the components that connect Maven to specific voice and telephony providers, did not have the same level of pre-production validation and production monitoring as our core platform. That gap is on us, and we're closing it. To prevent a recurrence, we are standing up a dedicated staging environment for voice integration components with real end-to-end escalation tests gating every release, adding production alerting and monitoring on the integration layer so anomalies are caught in minutes rather than by customer reports, and introducing fallback routing so a failure on the primary escalation path does not fail the call outright. Going forward, changes to these components will also be deployed outside of peak call-volume hours. We know voice escalation is a high-trust path. When a customer needs a human, nothing else matters. We're sorry for the disruption and appreciate your patience. If you'd like to discuss the incident or the remediation plan in more detail, please reach out to your account team directly.
Resolved
User now able to escalate
Identified
Users were able to have normal conversations with Maven Voice, but were not able to escalate to a human agent.