Write-up published
Resolved
The publishing delay has been resolved, and all previously affected knowledge bases have been restored.
Monitoring
We believe we’ve resolved the issues and are monitoring to confirm. We expect all affected KBs to be fixed within eight hours.
Monitoring
Current state:
Knowledge base edits and new documents added today are being indexed normally for the majority of customers.
Some changes made yesterday may not yet be fully reflected. As a quick workaround, making a small edit to a knowledge base will trigger reindexing.
Customers with very large knowledge bases (many hundreds of documents) may still experience delays. A targeted fix is currently being deployed and expected to be live within the next few hours.
Monitoring
We've pushed out a release that included changes decreasing the db load, and the system has recovered as expected.
Identified
We have identified specific database settings that have led to suboptimal performance in high ingestion loads; these have been changed and released to production.
Ingestion jobs are still backed off but we see faster completions of these jobs. We continue to monitor the process.
Investigating
We are seeing unresponsiveness or slowness in knowledge base creation possibly due to a spike in related workflows; we are investigating the root cause.