Resolved
The fix for the connectivity and timing issues has been deployed and verified.
Identified
We've identified the root causes and are pushing out the fixes now. The prior mitigation work has removed the impact from the affected components.
Investigating
The connection issues and timeouts have been mitigated and we've identified probably root causes, which we will start rolling out.